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Goals

By the end of this workshop you will know:
.1. about a ﬂexible set of technologies (XPath, XQuery, and native

.

...
...

XML databases) for answering questions about and publishing
your TEI documents

2

about eXist: a free, open-source native XML database

3

how to install and use eXist and oXygen to query and create a
website out of your TEI works

Completing the TEI Toolset
By now you've decided on:
TEI: Your data format
oXygen: Your XML editing Swiss army knife
Edit / author documents
Traverse documents with XPath tools
Transform documents with TEI XSLT

So what's missing?
An easy way to analyze and ask questions across any or all of
your TEI documents
A search engine and database for querying your content; think
of your TEI content as a database
A web server for publishing your TEI documents

There are many tools that might help you in each of these respects,
but eXist ﬁlls all these gaps in a very elegant way.

What is eXist?

a native XML database
a free, open source product
a community-driven project
TEI-friendly and popular among TEI users (and those with lots
of XML)
Integrates very nicely with oXygen

Brief Case Study
history.state.gov
Homepage of Oﬃce of the Historian (U.S. Department of State)
Launched January 2009, built 100% on eXist
TEI-based digital edition of Foreign Relations of the United
States, the oﬃcial documentary record of U.S. foreign relations
140+ volumes (and growing), containing 50,000+ primary
source archival documents
5-10 MB TEI ﬁle for each volume (total: 2 GB XML + 10 GB page
images)
Rapid full text search, research tools
Toolset:
oXygen for XML and XQuery authoring
eXist for website development and production server
An eXist-powered web-based content management system for
editing metadata as well as and editing and annotating TEI

Why a Native XML Database?
Tables

Trees
TEI!

teiHeader!
front!

text!

body!

Example data
Simple lists
Excel spreadsheets
Relational databases

Example data
HTML
XML
Taxonomies

Query Language
SQL

Query Language
XPath/XQuery

back!

Relational Database: a collection of tables (rows and columns)
for storing data and relationships - well-suited to tabular data
Native XML Database: uses XML documents as the
fundamental unit of storage and XML for the internal data
model - well-suited to complex, nested, 'semi-structured'
documents like TEI

eXist's ﬂavor of native XML database
Easy to download, install, and get started (Mac, PC, Linux)
Just drag and drop XML into the database (easiest via a
WebDAV client)
Supports XQuery, the W3C XML Query Language, for querying
XML
eXist automatically indexes the entire XML structure, so
structural (path) queries are much faster than searching ﬁles
on the ﬁlesystem
In addition, eXist's customizable indexing system let you
create fulltext search engines out of any TEI elements &
attributes you want, with Google-style query syntax
Query your documents quickly in the XQuery Sandbox
Save your queries into eXist, making them into web pages
Entire web applications can be written in XQuery (+ XSLT,
XHTML, CSS and Javascript)
Supports XPath, XSLT, XQuery Update, and Full Text Search
(leverages Lucene); ﬂexible URL rewriting

Getting eXist

Download from exist-db.org
(Windows users note: Requires Java JDK be installed ﬁrst)
Installing eXist actually puts all of the exist-db.org resources on
your computer
Searchable Documentation
Searchable Function Library
XQuery Sandbox (a real gem for quick queries)
Demos (get ideas, see examples of XQuery in action)

Before long, you'll have your TEI ﬁles stored in the eXist
database, and you'll be writing queries in the Sandbox and in
oXygen

XPath and XQuery in ~10 Minutes

Understanding XPath and XQuery is easy if you understand some
basics about XML — and you already do, since you use TEI!
Elements and their namespaces
Attributes
Text
These are all types of XML nodes. And from any node in an XML
document you can get to any other node, by traversing XPath axes.

XPath
XPath is a language for addressing parts of an XML document
(although it's not a full programming language.) It's common to
both XSLT and XQuery.
An XPath expression contains one or more "location steps",
separated by slashes. Each location step has the following
unabbreviated form: axis-name::node-test[predicate]
The most common XPath axes have abbreviated forms: child
(whose shorthand is /), parent (../), descendant-or-self (//), self (.),
and attribute (@) are the most common:
div/head returns all of a div's child head elements

Predicates, expressions encased in square brackets, restrict the
results to those that with match conditions:
//div[@type eq 'cartoon'] returns a sequence of the div

elements whose type attribute equals ‘cartoon’
//persName[. eq 'Cummings'] returns a sequence of the
persName elements whose value is ‘Cummings’

XPath Axes
Including these most common axes there are 13 total XPath axes:

Again, the pattern is axis-name::node-test[predicate]
following-sibling::pb returns a sequence of the sibling pb
elements that follow the current context
ancestor::div[@type eq 'chapter'] returns the ancestor div
elements whose type attribute is ‘chapter’

XQuery
XQuery builds on XPath, and is an easy-to-learn, ﬂexible, and
powerful language for querying XML and transforming it. By
storing your TEI in eXist, you can query across your entire TEI
corpus. You can also beneﬁt from eXist's XQuery Update
support, which allows you to alter XML in the database.
XQuery supports many expressions:
Literals (string literals like 'a' and numeric literals like 1)
Variables ($foo), to which you bind values
Functions, either built-in like substring-before('hello',
'l') or your own
Comments (: this is a comment! :)
Comparisons: =, <, >, eq
Conditionals: if then else
FLWOR Expressions: the core of XQuery

XQuery FLWOR Expressions
Unique to XQuery, FLWOR (pronounced ‘ﬂower’) Expressions give
you more control over your queries than XPath alone.
‘FLWOR’ stands for:
for: iterate through a sequence, assigning each item to a
variable ($ + a name of your choosing starting, e.g. $people)
let: name a sequence, assigning the whole sequence a variable
where: ﬁlter a sequence (optional)
order by: order a sequence (optional)
return: return the resulting sequence (required)
FLWOR expressions are great for ordering your results, and for
queries that are more complex than XPath allows

Example FLWOR Expressions
for $item in ('c', 'b', 'a')
order by $item
return $item

-> Returns ('a', 'b', 'c')
let $people := ('Lou', 'Sebastian', 'James')
for $person in $people
let $greeting := concat('Hello, ', $person)
return $greeting

-> Returns ('Hello, Lou', 'Hello, Sebastian', 'Hello, James')
for $role in doc('roj.xml')//tei:role
order by $role
return $role

-> Returns all role elements in alphabetical order

How to Alternate between XML and XQuery in your
queries
Soon you will be writing more complex queries that nest XQuery
expressions inside of XML. For example, you may write a table of
contents that displays chapter headings, and a list of section
headings inside this.
How to alternate between XML and XQuery? Curly braces {} !

That's the core of XQuery in ~10 minutes

TEI, eXist, oXygen, and XQuery

A typical set of steps for querying and developing TEI webpages
with eXist
Step 1: Get your TEI into eXist
Step 2: Browse/edit your TEI with oXygen through the
Database Explorer
Step 3: Write simple XQueries in the XQuery Sandbox
Step 4: Move to oXygen for turning your XQueries into web
pages

Step 1: Getting your TEI into eXist

There are several ways! The easiest is to drag and drop with a
WebDAV client
In Windows XP, go to My Network > Add Network Places >
http://localhost:8080/exist/webdav/db
Then just drag your ﬁles from the desktop into the eXist
WebDAV window
For other platforms, see the eXist homepage.

Step 2a: Browse/edit your TEI with oXygen
through the Database Explorer
Open oXygen's Data Source Explorer via Perspective > Show
View > Data Source Explorer
The Data Source Explorer window will open. Click on the
yellow gear icon above "Connections."
Under Data Sources, click on New.
Name the new data source as "eXist Data Source"
Select eXist from the "Type" dropdown menu
Add 5 ﬁles from your eXist installation directory: (1) exist.jar
from the main directory, and from lib/core, (2)
ws-commons-1.0.2.jar, (3) xmldb.jar, (4) xmlrpc-client-3.1.2.jar,
(5) xmlrpc-common-3.1.2.jar.

Under Connections, click on New
select your eXist data source
Name the connection "eXist on localhost 8080"
Change <host/> to "localhost"
Enter "admin" for username, and your eXist admin password.
Click OK.

Step 2b: Tell oXygen to use eXist to validate XQuery
By telling oXygen to use eXist to validate XQuery, you can get
feedback from eXist about any errors in the XQueries that you're
writing in oXygen:
Under oXygen Tools > Preferences > XQuery > XQuery Validate
With, select "eXist on localhost 8080"
Click OK.
Now, with these steps done, oXygen is fully conﬁgured to both
browse eXist's database and use it to provide feedback on your
XQuery work.
If the "Data Source Explorer" windows is not open in oXygen, open
it via Perspective > Show View > Data Source Explorer, and "pin" it
so it stays open.

Step 3: Write simple XQueries in eXist's XQuery Sandbox
oXygen's XPath/XQuery functions let us query a single document at
a time, but the eXist XQuery Sandbox lets us query our entire
collection of TEI ﬁles:
Go to http://localhost:8080/exist/sandbox and enter these
queries:
declare namespace tei = "http://www.tei-c.org/ns/1.0";
count( collection('/db/punch/data')/tei:TEI )

-> Returns the count of TEI ﬁles in the Punch collection
declare namespace tei = "http://www.tei-c.org/ns/1.0";
collection('/db/punch/data')//tei:name

-> Returns all TEI name elements in the Punch collection

Step 4: Move to oXygen for turning your XQueries into
web pages
The Sandbox is a powerful tool for individual exploration. Once
you've found queries that you want to turn into webpages, open
oXygen to create XQuery ﬁles.
Select File > New > XQuery
Paste a query from the Sandbox into the new window
Notice how oXygen highlights the XQuery and XML syntax
oXygen will tell you if your query is valid or not, just as it tells
you if your TEI is valid
Save the valid XQuery via File > Save to URL >
http://localhost:8080/exist/webdav/db/tei > myquery.xq
Open the query in your web browser at
http://localhost:8080/exist/rest/db/tei/myquery.xq

Exercises: Before You Start
Install eXist (from the ﬁle on the course's USB keychain
(eXist-setup-1.4.0-rev10440.jar), or download from exist-db.org
Set up WebDAV and oXygen (as detailed above)
Copy course ﬁles into eXist:
Copy the controller-conﬁg.xml ﬁle in
"ﬁles/controller-conﬁg.xml" into eXist's application directory, in
webapp/WEB-INF. Then stop and restart eXist.
Copy the index conﬁguration ﬁles in "ﬁles/db/system/conﬁg"
into their corresponding location in eXist's database, in the
"db/system/conﬁg" directory
Copy the punch directory in "ﬁles/db/punch" into eXist's
database

Now you're ready to begin the exercises.

Exercises
Query your TEI ﬁles from eXist's sandbox,
http://localhost:8080/exist/sandbox
Try querying Punch, and querying for elements you have
worked with.
Use predicates to ﬁlter your results, with the functions
contains(), starts-with(), and distinct-values().
Use FLWOR expressions to order your results.

Copy your queries into oXygen, save them to eXist, and call
them from your web browser, e.g. save 'myquery.xq' into
/db/punch/myquery.xq, and point your web browser to
http://localhost:8080/exist/punch/myquery.xq
When you're ready to create a full website around the Punch
data, open the sample Punch website,
http://localhost:8080/exist/punch/index.xq

Sample Punch Website

To understand how a website is assembled with XQuery in eXist, go
to the sample Punch website in
http://localhost:8080/exist/punch/index.xq.
The XQuery ﬁles (.xq, .xqm ﬁles) themselves are extensively
commented, so please open each ﬁle to read the comments and
understand.
The sample actually contains 4 versions of a Punch website — the
ﬁrst very simple, and the last polished.
Each "version" of the site improves the presentation and usefulness
of the site.

index.xq - Landing Page

http://localhost:8080/exist/punch/index.xq

Version 1: List issues

Version 4: List issues

Version 4: Show section

Version 4: Search results

Resources
There are many resources for learning about eXist and XQuery, and
for getting answers to your questions
Documentation on eXist: eXist Homepage http://exist-db.org
Best book about XQuery: XQuery, by Priscilla Walmsley
(O'Reilly 2007)
Best website for learning XQuery and eXist: XQuery Wikibook
http://en.wikibooks.org/wiki/XQuery
Questions about XQuery in general - XQuery-talk mailing list
http://x-query.com/mailman/listinfo/talk
Questions about eXist speciﬁcially - eXist-open mailing list
http://sourceforge.net/mail/?group_id=17691

